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UPGRADING

This booklet is for users who are upgrading from a previous version of
WordStar. It describes what to do before installing WordStar 7.0, gives brief
installation instructions, and tells you how to transfer customizations from a pre-
vious version of WordStar. It also includes a description of some of the new fea-
tures and other improvements in WordStar.

IMPORTANT The disks in your WordStar package are compressed.
These disks must be decompressed before you can run WordStar. Use the
WSSETUP program, which decompresses and copies the files, to install
WordStar.

BEFoRE YOU INSTALL WORDSTAR 7.0

Before you install WordStar 7.0, you should save any user-modifiable files you
customized in a previous version of WordStar. You can rename the files or
move them to a different directory or to a floppy disk. The user-modifiable files
are PERSONAL.DCT, EXCEPT.DCT, TELMERGE.SYS, WSSTYLE.OVR,
WSINDEX.XCL, *.PIX, WSLIST.DTA, and any other MailList™ files you’ve
modified. (Not all these files are available in versions of WordStar previous to
5.5.) If you've previously installed WordStar 7.0, be sure to move or copy any
macro files you've modified (* WSM). After you finish installing WordStar 7.0,
you can copy the user-modifiable files you saved to your new WordStar
directory.

You may want to save your old WSSHORT.OVR file. You can convert the
shorthand macros in this file to WordStar 7.0 macros using the WS6MACRO
utility described later in this booklet.
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WordStar 7.0 generally recognizes printer PDFs from WordStar 6.0. However,
color/shading choices have been improved for some printers, so you may want
to reinstall your printer.

You may also want to save your old FONTID.CTL file to save information on
how you configured Preview. If you installed custom screen fonts for Preview
in your previous version of WordStar, you can find the .WSF filenames in the
old FONTID.CTL. After you finish installation, run DISPFONT for each .WSF
file to update the new FONTID.CTL so WordStar 7.0 can access the custom
fonts. Start in the directory where DISPFONT is located (usually WS), and type
dispfont fontname, where fontname is the name of the .WSF file, including the
full path. Repeat this procedure for each .WSF file. Do not run DISPFONT for
the .WSFs provided with WordStar.

Before you use WordStar 7.0, run the DELCRT program to clear out Preview
screen font files and directories.

Be sure to delete your old PDFEDIT.COM file. The new version is
PDFEDIT.EXE, and you may not be able to access it if the old file remains on
your disk. (PDFEDIT must be run from DOS now; it is not available in
WINSTALL.)

The WordStar default directory name is WS; use this directory name if possible.
If you want to keep your old WordStar program files, be sure they are in a direc-
tory with a different name (move them if necessary), so you won’t overwrite any
files you want to keep.

IMPORTANT Ifyou plan to use a patch file to transfer customizations
from an earlier version of WordStar, see “Transferring Customizations” in this

booklet.

UPGRADING FROM WORDSTAR 5.5 OR EARLIER

If you're upgrading from a version earlier than WordStar 6.0, note these points:

= Your old personal dictionary is compatible with WordStar 7.0. However, it
may contain words that are now found in the new, larger main dictionary.
Duplicate words are unnecessary and can fill your personal dictionary
quickly. You can build a new personal dictionary from your old one and
eliminate duplicate words. First rename your old personal dictionary
PERSONAL.OLD. Use WordStar 7.0 to run a spelling check on
PERSONAL.OLD. Add the words flagged by WordStar to your new personal
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dictionary, PERSONAL.DCT. Now use PERSONAL.DCT as your new
personal dictionary.

= |tis recommended that you completely reinstall your printer using WordStar
7.0 to ensure that WordStar uses the correct fonts for printing and that you
get the best performance from Preview. Even if your old PDFs work fine for
editing and printing, they may not contain all the information Preview needs
to select the correct font for screen display. You should rebuild the display
fonts (\WSF files), custom fonts database files, and PDFs, using your original
downloadable font files.

= |f you intend to install Inset® in the same directory where you stored your
old Inset program files, you need to delete the IN.SET file from the directory
before you install Inset. Before using the new version of Inset, be sure to run
the Inset Setup program.

I NSTALLING WORDSTAR 7.0

To install WordStar 7.0, use the WSSETUP installation program. WSSETUP lets
you decide which WordStar features to install, decompresses the disks, copies
the files into the directories of your choice, and guides you through the installa-
tion of your monitor and printer. WSSETUP also defines search paths that allow
WordStar to locate files more quickly. To run WSSETUP, put the Installation
disk in drive A, log on to drive A, type wssetup, and press Enter.

For more information, see “Installing WordStar” in the Installing and
Customizing booklet.

NEW FEATURES

The new features and other improvements in WordStar 7.0 are described
below. For other information about other design and functionality changes, see
README. For complete information on the new features, see the WordStar 7.0
Reference manual.
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Macros WordStar has a new macro system, which includes the following
capabilities:

® You can record a macro. Just press the keys for the commands and text you
want to include in the macro. WordStar automatically compiles the macro
and saves it in a macro file.

® You can use the BASIC-like macro language to create and edit macros to
perform complex functions. And you can use the Single Step command to
run a macro step by step for easy debugging.

= You can run a macro using a hot key or the Play command.

The old shorthand system using the Esc key is no longer used. The Esc key is
now available for its standard function of cancelling or backing out of the cur-
rent operation. The preprogrammed values that were inserted using the Esc key
are now inserted using the Insert pull-down menu or the new M classic menu.
For example, Esc@ previously inserted the current date; now, you can choose
Insert =Today’s Date Value or press M@ to insert the date. You can convert
shorthand macros to WordStar 7.0 macros using the WS6MACRO utility; see
“Converting Shorthand Macros” in this booklet.

The macro system is also used for all the function keys. The function keys work
as they did in previous versions. You can change a function key assignment by
editing or rerecording the macro.

The /m command line option runs a macro when you start WordStar. Pre-
viously, /[ and /e were used to run a macro.

Integrated graphics conversion You can insert graphics from a number of
programs directly into your documents. WordStar recognizes the filename
extension when you select the file to insert. It then converts the graphic into a
.PIX file and inserts the .PIX file. You can change several output file options for
the conversion.

Fax support You can use a new command to create .PCX fax files, which you
can send using your fax board and software. The fax output looks similar to out-
put from the Hewlett-Packard Laser]et Il printer.

Windows Clipboard support You can copy blocks of text up to 64K to and
from the Microsoft Windows Clipboard.
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Mouse support You can use a mouse to choose commands from pull-down
menus, fill in dialog boxes, move around in your file, mark blocks, and change
editing settings.

EMS support WordStar uses expanded memory (EMS), when it’s available, to
run faster and provide more functionality. You can set the level of EMS support
using WSCHANGE (CC2G). When sufficient EMS is available, you can now
run Preview, Inset, the thesaurus, or background printing when you have two
windows open.

New screen design The new screen design features the following:

= Redesigned pull-down menus, which contain virtually all the WordStar
commands, including dot commands. (The classic menus are unchanged
except for the addition of new commands, and you can still enter classic
commands and dot commands the way you’ve always entered them.)

= A new Editing screen, which includes a style bar with settings you can
change using a mouse. It also includes a vertical scroll bar that shows your
relative location in the document and lets you scroll with a mouse. You can
remove or move several screen elements using WSCHANGE (DBA) or using
View=>Screen Settings, or AOB. You can also use WSCHANGE (DBH2F) to
change to the screen elements used in previous versions of WordStar.

= New dialog boxes that help you to set many options easily.
= Online help for each command and for each option in every dialog box.

Hide dot commands In addition to hiding command tags, ~OD, or
View=>Command Tags, now also turns the display of dot commands on and
off. (You can set WordStar to always display dot commands using WSCHANGE
(DBAE) or View=>Screen Settings (*OB).)

Printing and merge printing You don’t have to choose between printing and
merge printing when you print a file. The Interpret Merge Variables print
option is selected by default. To print a file and ignore the merge printing com-
mands and variables, just turn the option off. The /m command line option to
merge print when you start WordStar is no longer needed, because /p works for
both printing and merge printing now; /m is now used to run a macro.

Write a block to ASCII file  When you choose Edit=>Copy=>To Another File,
or AKW, you can choose to copy the block in ASCII format.
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Re-mark or unmark a block The new Edit->Mark Previous Block command, or
AKU, marks the block that was marked before you marked the current one.

You can use it to work with two blocks of text at once. The new AK< com-
mand unmarks a block (rather than just hiding the markers).

Improved support for colors and shading When you choose
Style=>Other=>Color/Shading, or AP-, the list of colors or shades that appears
shows the correct choices for your printer. In previous versions, the list showed
the 16 standard colors even if the choices for your printer were different.

Preview improvements Preview supports more monitors and video modes,
including monochrome monitors with inverse video. You can check the
FONTID.CTL file for more information. The Preview screen fonts have a better
appearance. Several monitors are no longer automatically selected. If the
Preview display appears incorrect, edit the FONTID.CTL file to select the
correct monitor.

Improved paper bin support When you choose Layout=>Page, or AOY, and
select Paper Bin, the names of the paper bins supported by your printer are
listed. Previously, you had to type the .bn command and remember the num-
ber for the bin. (The .bn commands still work as they did in previous versions if
you prefer to type them.)

Go to a style tag Choose Edit=>Go to Other => Style Tag, or press ~Q<, to go to
the next paragraph style tag.

Support for many new printers WordStar supports over 550 printers. See the
Printers and Monitors List. Scalable font support is available for IBM 4029,
Ricoh 4150 Flex, and Epson ESC P-2 printers as well as those that were already
supported: PostScript, HP LaserJet 1ll, Canon LBP-4 and LBP-8/Ill, and OkiLaser
820 printers.

More WSCHANGE options Many new WSCHANGE options have been
added, allowing users to customize even more WordStar settings than in pre-
vious versions. For example, you can now change automatic leading to 120%
of the text size. Also, the default paths and filenames options in WSCHANGE
are improved; you can specify the drive and directory together, and specify
primary and secondary paths for files instead of one path.

TelMerge® improvements TelMerge supports the COM3 and COM4 ports on
most systems.
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Star Exchange™ improvements You can run Star Exchange from the WordStar
Opening screen; choose Additional—>Star Exchange or press AS. Star Exchange
has several new capabilities and supports a number of additional file formats,
including dBASE IV, Lotus 1-2-3 version 3.0, and Apple Macintosh format. If
you're updating from a version previous to WordStar 6.0, note that you can
now convert files without identifying the source word processor using the Auto
Translate feature.

Additional improvements More improvements and changes include the
following:

= Justification is now off as a default.

= When you change a tab stop setting from regular to decimal and vice versa,
you no longer have to delete and reenter each tab for the change to take
effect.

= When you move through a list (for example, a list of filenames), you can use
the PgUp and PgDn keys to scroll through the list.

= The Enter key now closes a dialog box. You can set Enter to move from
option to option in dialog boxes by choosing Set basic editing options in
WINSTALL.

= When you open a second window on the same file, the version in the
second window is protected so you don’t accidentally overwrite your
changes.

= Screen fonts for code page 850 and for PostScript are included with
WordStar. You can use WSSETUP or the WINSTALL Add a Feature option to
install them.

= You have more choices for setting onscreen colors. You can still choose the
default colors and customize individual color assignments. You can also use
and modify two custom color palettes, and you have two choices for
monochrome monitors (depending on whether your monitor can display
underlined words).

New features in WordStar 6.0 If you're upgrading from a version previous to
WordStar 6.0, or from an early revision of WordStar 6.0, you'll be interested in
these features that were added in WordStar 6.0:
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= Scalable font support Instead of installing point sizes when you install a
scalable font, you install the font once. Then, while editing in WordStar, you
can specify any point size. Subscript and superscript text is scaled in relation
to the size of the font you are using. You can create your own scalable fonts
for HP Laserlet 11l and PostScript printers using Type Director 2.0 or other
products that support Autofont technology or PostScript. You can also still
use Type Director or Bitstream Fontware to create regular (bitmapped) fonts
to use with WordStar.

= Kerning WordStar supports kerning on PostScript printers and on some HP
LaserJet and compatible printers.

= Expanded support for entering international characters WordStar now
includes a “dead key” method of composing characters for which there are
no dedicated keys on your keyboard. This method provides an easy way to
enter and display characters with accent marks, tildes, umlauts, and other
diacritical marks into documents.

= Code Page 850 support When you install it to use code page 850,
WordStar recognizes extended characters as parts of words when you move
the cursor or run a spelling check. You can install screen fonts to display
these characters. The code page 850 characters can be printed on any
printer that supports the PC-850 symbol set.

= Improvements to the spelling checker The spelling checker offers
suggestions from the personal dictionary; previously, suggestions came only
from the main dictionary. You can create a spelling exceptions dictionary
that contains correctly spelled words that you want to flag. For example, if
you often type “fro” when you mean “for,” you can add “fro” to your
exceptions dictionary.

= Support for international thesauruses When you change the spelling check
language (Utilities=>Language Change, or .la), the thesaurus for the
appropriate language is used. International dictionaries and thesauruses are
available in language packs from WordStar.

= Vertical cursor movement You can control the way the cursor moves
vertically in documents. Use WSCHANGE (DBHK) to choose one of three
vertical cursor movement options.
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= Hyphenation The .hy on/off command (Layout=>Alignment and Spacing)
allows you to turn hyphenation on and off for subsequent text.

= Suppress blank lines The .sb on/off command (Layout—>Page) allows you to
suppress printing of blank lines that fall at the top of a page.

= Optional prompts You can turn off some prompts in WSCHANGE: Can’t
find that file. Create a new one?, which appears when you choose a file to
edit; the number of words checked at the end of a spelling check; and Press
any key to return to WordStar, which appears after you run a DOS program.

CONVERTIN G SHORTHAND MACROS

To use your old shorthand macros, convert them to WordStar 7.0 macros using
the WS6MACRO utility. Follow these steps:

1 Change to your new macros directory (usually WS\MACROS).

2 At the DOS prompt, type wsbmacro shorthandfile, and press Enter. For the
shorthandfile, type the path and filename for your old WSSHORT.OVR file.
(If you copy WSSHORT.OVR to the WS\MACROS directory, you don’t have
to include the filename and path.)

WS6MACRO converts your shorthand macros to new macros. The shorthand
keystroke is used as the macro name (for example, ESC-E.WSM), and the
shorthand description is used as the new macro description. No hot key is
assigned to the macro. You can use Utilities=>Macros=>Rename (or ME at the
Opening screen or AME at the Editing screen) to assign a hot key to each
macro. For more information on working with macros, see “Macros” in
“Editing Screen Utilities Menu” in the Reference manual.

Note: The WordStar M command inserted a carriage return in previous ver-
sions of WordStar; now it displays the Macros menu. In converted macros, any
instances of AM are changed to {Enter}. Also keep in mind that if a shorthand
macro called another macro, you need to edit the new macro and replace the
Esc key sequence with the appropriate keystrokes.
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USING WORDSTAR DOCUMENTS FROM PREVIOUS
VERSIONS

If you have documents and nondocuments from a previous version of
WordStar, you can use those files with this version. However, if you reinstalled
your printer when you installed WordStar 7.0, you may need to update your
documents for the new PDF.

If your documents were created using WordStar 6.0, and you reinstalled your
printer using the same PDF name, you don’t need to update your documents
unless the font selections for your printer have changed.

If your documents were created with a version previous to WordStar 6.0, follow
these steps:

7 Open the document.

2 If the new PDF name is different from the old one, choose File=>Change
Printer or press AP?, and select the new PDF.

3 To check the default font used, choose Style=>Font or press AP=. Change
the font if necessary. If the document contains font tags, check them and
repeat this step to make any necessary changes.

4 Choose Edit=>Go to Other=>Document Beginning.

5 Choose Utilities=>Reformat=>Rest of Document or press AQU to reformat
the document for the new printer and fonts.

When you use WordStar 7.0 to edit files created with a version previous to
WordStar 5, you may need to modify some page layout dot commands. Prior
to WordStar 5, the width of a column was determined by the size of the font.
Now each column has a standard width of .1 inch. If you used dot commands
to change margins or tabs (.rm, .Im, .pm, .rr, .po, or .pc), you need to modify
these dot commands based on the new column width.

For example, if you used a small font, you may have set the right margin to 80

(.rm80) to have text extend 6.5 inches across the page. Now, you specify 65
columns or 6.5 inches (.rm 65 or .rm 6.5") for the same margin.
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If your documents contain .cw commands to change fonts, these commands
may not work as they did in earlier versions. Use Style=>Font or ~P= to choose
a font.

You can use WordStar 5, 5.5, or 6.0 to edit files created with WordStar 7.0, but
you should avoid features that weren’t available in those versions, such as
(depending on the version) automatic leading, centimeters and points as units of
measurement in dot commands, and paragraph styles. To edit a WordStar 7.0
document using WordStar 4, you must convert the document to WordStar 4 for-
mat. Print the document using WS4.PDF as the printer, and redirect the output
to a file. Then edit the new file.

TRANSFERRING CUSTOMIZATIONS

The following information is for advanced WordStar users who want to use a
patch file to transfer program customizations from a previous version (WordStar
4 or later) to this version. If you plan to change the settings manually in
WSCHANGE, you don’t need to read this information.

CAUTION Because many labels have been changed or deleted, it is highly
recommended that you install WordStar 7.0 and then manually customize the
program in WSCHANGE instead of editing and transferring a patch file from an
earlier WordStar version. However, if you're planning to transfer customiza-
tions, read the following instructions carefully.

A patch file can be used to transfer customizations from a previous WordStar
version to WordStar 7.0. You can create a patch file in nondocument mode (for
advanced users only) or you can choose Save settings on the Patching Menu in
WSCHANGE. The patch file lists the starting location for the program cus-
tomization information and the information for that location. For more informa-
tion about patching, see “Advanced Customizing” in the Installing and
Customizing booklet.

Note: It's a good idea to make a copy of your patch file before editing it.

After you install WordStar 7.0, use the auto-patcher on the WSCHANGE Patch-
ing Menu to transfer the patch file to WordStar.
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If the auto-patcher finds any of the following labels in your patch file, it ignores
them; they are no longer used in WordStar 7.0. For explanations of each label,
see the PATCH.LST file.

ALTRWD FUNLAB NORMWD STKOFF
BACKSP FUNTBL OPNTBL STKON
BINDSP GRPHMK OVFILE STYSIZ
BLDOFF HALFLF OVSIZE SUBOFF
BLDON HFMAX PFFEED SUBON
BPRSPD INIDOC PHRUB SVFILE
CASTBL INIRLI PHSP UDMEM
COMEXT INIRLR PPAUSE ULINI
COMPOS ITLOFF PRMTBL ULUNI
CRET ITLON PSTSIZ UNDOFF
CRLF LANGS QDFILE UNDON
DBLOFF LCHRMX SHEET UPRCTL
DBLON LETX SHTID UPRE
DEFUSR LRUSIZ SPALGN UPRQ
DLIST LSTDEV SPLMEM UPRR
EXTOFF LSTRED SPMEM UPRW
EXTON LXOFF SPROFF YNCR
FORMF NLQOFF SPRON

FUNDLY NLQON SPSIZE
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If the auto-patcher finds any of the following labels in your patch file, it ignores
them unless your patch file was created with WordStar 7.0.

Note: A WordStar 7.0 patch file is identified by the UDATE label. For more
information on UDATE, see “Advanced Customizing” in the Installing and
Customizing booklet.

BFRSIZ HPFILE MLFILE STFILE
CFFILE HYFILE MORPAT TDFILE
DDFILE IDFILE MSFILE THFILE
DEFPTH INIEDT NOTYPE TMFILE
DSTKSZ ISFILE NWFLG UDATE
EMSMEM IXFILE PDFFILE UDFILE
EXFILE KBFILE PRFILE VCOLOR
EXTKB KBXLAT PVFILE VIDATT
FNFILE LNGCOD PVWEFILE WRKTYP
HDFILE MDFILE SCMARK

HIFILE MEMFLG SPFILE

If your patch file from an earlier version has the labels WID, UDMEM, or
SPLMEM, they are patched as the new labels WIDE, UDCMEM, and SPMMEM.
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